dev-libs/leatherman: 1.12.0 stable amd64/x86 with cleanup
[gentoo.git] / dev-libs / hyperscan / hyperscan-5.2.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6..8} )
7
8 inherit cmake flag-o-matic python-any-r1
9
10 DESCRIPTION="High-performance regular expression matching library"
11 SRC_URI="https://github.com/intel/hyperscan/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 HOMEPAGE="https://www.hyperscan.io/ https://github.com/intel/hyperscan"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="+cpu_flags_x86_ssse3 static-libs"
18
19 RDEPEND="dev-libs/boost"
20 DEPEND="${RDEPEND}"
21 BDEPEND="
22         ${PYTHON_DEPS}
23         dev-util/ragel
24 "
25
26 REQUIRED_USE="cpu_flags_x86_ssse3"
27
28 src_prepare() {
29         # upstream workaround
30         append-cxxflags -Wno-redundant-move
31         cmake_src_prepare
32 }
33
34 src_configure() {
35         local mycmakeargs=(
36                 -DBUILD_SHARED_LIBS=$(usex static-libs OFF ON)
37                 -DBUILD_STATIC_AND_SHARED=$(usex static-libs ON OFF)
38         )
39         cmake_src_configure
40 }
41
42 src_test() {
43         "${BUILD_DIR}"/bin/unit-hyperscan || die
44 }