Drop $Id$ per council decision in bug #611234.
[gentoo.git] / dev-libs / hyperleveldb / hyperleveldb-1.2.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 WANT_AUTOMAKE="1.11"
7
8 inherit eutils autotools
9
10 DESCRIPTION="Hyperdex fork/extension of leveldb"
11 HOMEPAGE="http://hyperdex.org/"
12 SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="
20         dev-libs/leveldb[snappy]
21         "
22 RDEPEND="${DEPEND}"
23
24 src_prepare() {
25         epatch "${FILESDIR}/snappy.patch"
26         eautoreconf
27 }