dev-libs/granite: Don't explicitly set libdir.
[gentoo.git] / dev-libs / granite / granite-0.5.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 VALA_MIN_API_VERSION=0.32
7
8 inherit gnome2-utils vala cmake-utils versionator
9
10 DESCRIPTION="Elementary OS library that extends Gtk+"
11 HOMEPAGE="https://github.com/elementary/granite"
12 SRC_URI="https://github.com/elementary/${PN}/archive/$(get_version_component_range 1-2).tar.gz -> ${P}.tar.gz"
13
14 LICENSE="LGPL-3"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm x86"
17 IUSE="demo nls test"
18
19 RDEPEND="
20         dev-libs/glib:2
21         dev-libs/libgee:0.8[introspection]
22         >=x11-libs/gtk+-3.14:3[introspection]"
23 DEPEND="${RDEPEND}
24         $(vala_depend)
25         virtual/pkgconfig
26         nls? ( sys-devel/gettext )"
27
28 S="${WORKDIR}"/"${PN}"-"$(get_version_component_range 1-2)"
29
30 src_prepare() {
31
32         # Disable building of the demo application (if needed)
33         use demo || cmake_comment_add_subdirectory demo
34
35         # Disable generation of the translations (if needed)
36         use nls || cmake_comment_add_subdirectory po
37
38         cmake-utils_src_prepare
39         vala_src_prepare
40 }
41
42 src_configure() {
43         local mycmakeargs=(
44                 -DVALA_EXECUTABLE=${VALAC}
45         )
46
47         cmake-utils_src_configure
48 }
49
50 pkg_preinst() {
51         gnome2_icon_savelist
52 }
53
54 pkg_postinst() {
55         gnome2_icon_cache_update
56 }
57
58 pkg_postrm() {
59         gnome2_icon_cache_update
60 }