dev-python/csv23: arm64 keyworded (bug #719700)
[gentoo.git] / dev-libs / gost-engine / gost-engine-1.1.0.3_p20181031-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-utils
7
8 DESCRIPTION="A reference implementation of the Russian GOST crypto algorithms for OpenSSL"
9 HOMEPAGE="https://github.com/gost-engine/engine"
10 IUSE="test"
11 RESTRICT="!test? ( test )"
12 SLOT="0/${PV}"
13
14 COMMON_DEPEND=">=dev-libs/openssl-1.1.1:0="
15 DEPEND="${COMMON_DEPEND}
16         virtual/pkgconfig
17         test? (
18                 dev-lang/perl
19         )"
20 RDEPEND="${COMMON_DEPEND}"
21
22 LICENSE="openssl"
23
24 DOCS=( INSTALL.md README.gost README.md )
25
26 if [[ ${PV} == "9999" ]] ; then
27         SRC_URI=""
28         EGIT_REPO_URI="https://github.com/gost-engine/engine.git"
29         inherit git-r3
30 else
31         KEYWORDS="~amd64 ~hppa"
32         SRC_URI="https://github.com/gost-engine/engine/archive/e5cc3684f3b3ad40e186e23b00b253d234df92ab.tar.gz -> ${P}.tar.gz"
33         S="${WORKDIR}/engine-e5cc3684f3b3ad40e186e23b00b253d234df92ab"
34 fi