dev-libs/gom: version bump to 0.3.2
[gentoo.git] / dev-libs / gom / gom-0.3.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 GCONF_DEBUG="yes"
7
8 inherit gnome2
9
10 DESCRIPTION="GObject to SQLite object mapper library"
11 HOMEPAGE="https://wiki.gnome.org/Projects/Gom"
12
13 LICENSE="LGPL-2+"
14 SLOT="0"
15
16 IUSE="+introspection test"
17 KEYWORDS="amd64 ~ppc ~ppc64 x86"
18
19 RDEPEND="
20         >=dev-db/sqlite-3.7:3
21         >=dev-libs/glib-2.36:2
22         introspection? ( >=dev-libs/gobject-introspection-1.30.0 )
23 "
24 DEPEND="${RDEPEND}
25         >=dev-util/gtk-doc-am-1.14
26         >=dev-util/intltool-0.40.0
27         sys-devel/gettext
28         virtual/pkgconfig
29         x11-libs/gdk-pixbuf
30 "
31
32 src_configure() {
33         gnome2_src_configure \
34                 --disable-static \
35                 $(use_enable introspection) \
36                 $(use_enable test glibtest)
37 }