54ee9ab692e5ff63882cb51b3ac40bef958f33cc
[gentoo.git] / dev-libs / gobject-introspection-common / gobject-introspection-common-1.50.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 GNOME_ORG_MODULE="gobject-introspection"
6
7 inherit gnome.org
8
9 DESCRIPTION="Build infrastructure for GObject Introspection"
10 HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
11
12 LICENSE="HPND"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE=""
16
17 RDEPEND="!<${CATEGORY}/${PN/-common}-${PV}"
18 # Use !<${PV} because mixing gobject-introspection with different version of -common can cause issues like:
19 # https://forums.gentoo.org/viewtopic-p-7421930.html
20
21 src_configure() { :; }
22
23 src_compile() { :; }
24
25 src_install() {
26         dodir /usr/share/aclocal
27         insinto /usr/share/aclocal
28         doins m4/introspection.m4
29
30         dodir /usr/share/gobject-introspection-1.0
31         insinto /usr/share/gobject-introspection-1.0
32         doins Makefile.introspection
33 }