dev-libs/gobject-introspection-common: sparc stable wrt bug #587010
[gentoo.git] / dev-libs / gobject-introspection-common / gobject-introspection-common-1.48.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6 GNOME_ORG_MODULE="gobject-introspection"
7
8 inherit gnome.org
9
10 DESCRIPTION="Build infrastructure for GObject Introspection"
11 HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
12
13 LICENSE="HPND"
14 SLOT="0"
15 KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 IUSE=""
17
18 RDEPEND="!<${CATEGORY}/${PN/-common}-${PV}"
19 # Use !<${PV} because mixing gobject-introspection with different version of -common can cause issues like:
20 # https://forums.gentoo.org/viewtopic-p-7421930.html
21
22 src_configure() { :; }
23
24 src_compile() { :; }
25
26 src_install() {
27         dodir /usr/share/aclocal
28         insinto /usr/share/aclocal
29         doins m4/introspection.m4
30
31         dodir /usr/share/gobject-introspection-1.0
32         insinto /usr/share/gobject-introspection-1.0
33         doins Makefile.introspection
34 }