dev-libs/*: Update Manifest hashes
[gentoo.git] / dev-libs / gf2x / gf2x-1.0-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit autotools-utils
7
8 PACKAGEID=27999 # hack
9
10 DESCRIPTION="C/C++ routines for fast arithmetic in GF(2)[x]"
11 HOMEPAGE="http://gf2x.gforge.inria.fr/"
12 SRC_URI="http://gforge.inria.fr/frs/download.php/${PACKAGEID}/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
17 IUSE="bindist static-libs"
18
19 src_configure() {
20         local myeconfargs=(
21                 ABI=default
22                 )
23
24         if use bindist ; then
25                 if use x86 ; then
26                         myeconfargs+=(
27                                 --disable-sse2
28                         )
29                 fi
30                 if use amd64 ; then
31                         myeconfargs+=(
32                                 --disable-pclmul
33                         )
34                 fi
35         fi
36
37         autotools-utils_src_configure
38 }