dev-libs/gf-complete: [QA] inherit ltprune.eclass directly
[gentoo.git] / dev-libs / gf-complete / gf-complete-0.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools eutils ltprune
7
8 DESCRIPTION="A Comprehensive Open Source Library for Galois Field Arithmetic"
9 HOMEPAGE="http://jerasure.org/"
10 SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/${P}.tar.gz"
11 S="${WORKDIR}/${PN}.git"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE=""
17
18 DEPEND=""
19 RDEPEND="${DEPEND}"
20
21 src_prepare() {
22         sed -i -e 's/ -O3 $(SIMD_FLAGS)//g' src/Makefile.am tools/Makefile.am test/Makefile.am examples/Makefile.am|| die
23         eautoreconf
24 }
25
26 src_install() {
27         default
28         prune_libtool_files
29 }