dev-libs/geoip: dropped ~ia64-linux ~x86-freebsd
[gentoo.git] / dev-libs / geoip / geoip-1.6.9.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit autotools eutils
7
8 DESCRIPTION="GeoIP Legacy C API"
9 HOMEPAGE="https://github.com/maxmind/geoip-api-c"
10 SRC_URI="
11         https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz
12 "
13
14 # GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
15 LICENSE="LGPL-2.1 GPL-2 MaxMind2"
16 SLOT="0"
17 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
18 IUSE="static-libs"
19 RESTRICT="test"
20
21 DEPEND="net-misc/wget"
22 RDEPEND="${DEPEND}"
23
24 S="${WORKDIR}/${PN}-api-c-${PV}"
25
26 src_prepare() {
27         eautoreconf
28 }
29
30 src_configure() {
31         econf $(use_enable static-libs static)
32         sed -e "s|@PREFIX@|${ROOT}|g" "${FILESDIR}"/geoipupdate-r5.sh > geoipupdate.sh || die
33 }
34
35 src_install() {
36         default
37
38         dodoc AUTHORS ChangeLog NEWS.md README*
39
40         prune_libtool_files
41
42         keepdir /usr/share/GeoIP
43
44         dosbin geoipupdate.sh
45 }
46
47 pkg_postinst() {
48         ewarn "WARNING: Databases are no longer installed by this ebuild."
49         elog "Don't forget to run 'geoipupdate.sh -f' (or geoipupdate from"
50         elog "net-misc/geoipupdate) to populate ${ROOT}/usr/share/GeoIP/"
51         elog "with geo-located IP address databases."
52 }