dev-libs/gdl: amd64 stable wrt bug #670024
[gentoo.git] / dev-libs / gdl / gdl-3.28.0.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit gnome2
6
7 DESCRIPTION="GNOME docking library"
8 HOMEPAGE="https://git.gnome.org/browse/gdl"
9
10 LICENSE="LGPL-2.1+"
11 SLOT="3/5" # subslot = libgdl-3 soname version
12 IUSE="+introspection"
13 KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
14
15 RDEPEND="
16         dev-libs/glib:2
17         >=x11-libs/gtk+-3.0.0:3[introspection?]
18         >=dev-libs/libxml2-2.4:2
19         introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
20 "
21 DEPEND="${RDEPEND}
22         >=dev-util/gtk-doc-am-1.4
23         >=dev-util/intltool-0.40.4
24         virtual/pkgconfig
25 "
26
27 src_configure() {
28         gnome2_src_configure \
29                 $(use_enable introspection) \
30                 --disable-gtk-doc
31 }