dev-libs/gdl: version bump 3.20.0 → 3.22.0
[gentoo.git] / dev-libs / gdl / gdl-3.20.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6 inherit gnome2
7
8 DESCRIPTION="GNOME docking library"
9 HOMEPAGE="https://git.gnome.org/browse/gdl"
10
11 LICENSE="LGPL-2.1+"
12 SLOT="3/5" # subslot = libgdl-3 soname version
13 IUSE="+introspection"
14 KEYWORDS="~alpha amd64 hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
15
16 RDEPEND="
17         dev-libs/glib:2
18         >=x11-libs/gtk+-3.0.0:3[introspection?]
19         >=dev-libs/libxml2-2.4:2
20         introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
21 "
22 DEPEND="${RDEPEND}
23         >=dev-util/gtk-doc-am-1.4
24         >=dev-util/intltool-0.40.4
25         virtual/pkgconfig
26 "
27
28 src_configure() {
29         gnome2_src_configure $(use_enable introspection)
30 }