Merge remote-tracking branch 'jirutka/lxc-grsec'
[gentoo.git] / dev-libs / gdl / gdl-3.14.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 GCONF_DEBUG="no"
7
8 inherit gnome2
9
10 DESCRIPTION="GNOME docking library"
11 HOMEPAGE="https://developer.gnome.org/gdl/"
12
13 LICENSE="LGPL-2.1+"
14 SLOT="3/5" # subslot = libgdl-3 soname version
15 IUSE="+introspection"
16 KEYWORDS="~alpha amd64 hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
17
18 RDEPEND="
19         dev-libs/glib:2
20         >=x11-libs/gtk+-3.0.0:3[introspection?]
21         >=dev-libs/libxml2-2.4:2
22         introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
23 "
24 DEPEND="${RDEPEND}
25         >=dev-util/gtk-doc-am-1.4
26         >=dev-util/intltool-0.40.4
27         virtual/pkgconfig
28 "
29
30 src_configure() {
31         DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
32         gnome2_src_configure $(use_enable introspection)
33 }