sys-apps/gawk: stable 5.0.1 for ppc64, bug #725374
[gentoo.git] / dev-libs / fstrm / fstrm-0.3.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools multilib-minimal
6
7 DESCRIPTION="Frame Streams implementation in C"
8 HOMEPAGE="https://github.com/farsightsec/fstrm"
9 SRC_URI="https://github.com/farsightsec/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="Apache-2.0"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm arm64 ~hppa ~mips ppc ppc64 ~s390 ~sparc x86"
14 IUSE="static-libs utils"
15
16 RDEPEND="utils? ( dev-libs/libevent[${MULTILIB_USEDEP}] )"
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig[${MULTILIB_USEDEP}]"
19
20 src_prepare() {
21         default
22         eautoreconf
23         multilib_copy_sources
24 }
25
26 multilib_src_configure() {
27         econf \
28                 $(use_enable static-libs static) \
29                 $(use_enable utils programs)
30 }
31
32 multilib_src_install_all() {
33         default
34         find "${ED}" -name '*.la' -delete
35 }