Merge github#758: media-sound/mpd: fix the systemd user service
[gentoo.git] / dev-libs / ferrisloki / ferrisloki-3.0.13.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit eutils multilib
8
9 DESCRIPTION="Loki C++ library from Modern C++ Design"
10 HOMEPAGE="http://www.libferris.com/"
11 SRC_URI="mirror://sourceforge/witme/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
16 IUSE="static-libs stlport"
17
18 RDEPEND="stlport? ( >=dev-libs/STLport-5 )
19         dev-libs/libsigc++:2"
20 DEPEND="${RDEPEND}
21         virtual/pkgconfig"
22
23 src_prepare() {
24         # derice this damn configure script
25         sed -i \
26                 -e '/^CFLAGS/{s: -O3 : :g;s:-Wl,-O1 -Wl,--hash-style=both::;}' \
27                 -e 's:-lstlport_gcc:-lstlport:' \
28                 configure || die
29
30         epatch_user
31 }
32
33 src_configure() {
34         econf \
35                 --libdir="${EPREFIX}/usr/$(get_libdir)" \
36                 --with-stlport="${EPREFIX}/usr/include/stlport" \
37                 $(use_enable stlport) \
38                 $(use_enable static-libs static)
39 }
40
41 src_install() {
42         default
43         prune_libtool_files
44 }