dev-libs/libsavitar: version bump to 4.6.1
[gentoo.git] / dev-libs / distorm64 / distorm64-3.4.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
11 HOMEPAGE="http://www.ragestorm.net/distorm/"
12
13 MY_PN=distorm3
14 MY_P=${MY_PN}-${PV}
15
16 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
17 S="${WORKDIR}/${MY_P}"
18
19 DEPEND=""
20 RDEPEND=""
21
22 LICENSE="BSD-4"
23 SLOT="0"
24 KEYWORDS="~amd64 ~x86"
25 IUSE=""
26
27 python_install() {
28         distutils-r1_python_install
29
30         # don't know why it does not happen by default
31         python_optimize
32 }