media-gfx/splash-themes-livecd: Merge gentoo-functions use fix
[gentoo.git] / dev-libs / darts / darts-0.32.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 DESCRIPTION="A C++ template library that implements Double-Array"
6 HOMEPAGE="http://chasen.org/~taku/software/darts/"
7 SRC_URI="http://chasen.org/~taku/software/darts/src/${P}.tar.gz"
8
9 LICENSE="|| ( BSD LGPL-2.1 )"
10 SLOT="0"
11 KEYWORDS="amd64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
12 IUSE="zlib"
13 DEPEND="zlib? ( sys-libs/zlib )"
14
15 src_compile() {
16         econf `use_with zlib` || die
17         emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die
18 }
19
20 src_install() {
21         emake DESTDIR="${D}" install || die
22
23         dodoc AUTHORS ChangeLog NEWS README || die
24         dohtml doc/* || die
25 }