dev-python/csv23: arm64 keyworded (bug #719700)
[gentoo.git] / dev-libs / darts / darts-0.32.ebuild
1 # Copyright 2003-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 DESCRIPTION="A C++ template library that implements Double-Array"
7 HOMEPAGE="http://chasen.org/~taku/software/darts/"
8 SRC_URI="http://chasen.org/~taku/software/darts/src/${P}.tar.gz"
9
10 LICENSE="|| ( BSD LGPL-2.1 )"
11 SLOT="0"
12 KEYWORDS="amd64 ~arm64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
13 IUSE="zlib"
14
15 BDEPEND=""
16 DEPEND="zlib? ( sys-libs/zlib )"
17 RDEPEND="${DEPEND}"
18
19 src_configure() {
20         econf $(use_with zlib)
21 }
22
23 src_compile() {
24         emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
25 }
26
27 src_install() {
28         default
29
30         dodoc AUTHORS ChangeLog
31         (
32                 docinto html
33                 dodoc doc/*
34         )
35 }