dev-libs/cppcodec: Correct license
[gentoo.git] / dev-libs / cppcodec / cppcodec-0.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 : ${CMAKE_MAKEFILE_GENERATOR:=ninja}
7 inherit cmake-utils
8
9 DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
10 HOMEPAGE="https://github.com/tplgy/cppcodec"
11
12 if [[ ${PV} == *9999 ]]; then
13         inherit git-r3
14         EGIT_REPO_URI="https://github.com/tplgy/cppcodec.git"
15
16         # Disable pulling in catch
17         EGIT_SUBMODULES=()
18 else
19         SRC_URI="https://github.com/tplgy/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
20         KEYWORDS="~amd64"
21 fi
22
23 LICENSE="MIT"
24 SLOT="0"
25 IUSE="test"
26 RESTRICT="!test? ( test )"
27
28 DEPEND="
29         test? (
30                 virtual/pkgconfig
31                 >=dev-cpp/catch-2.2.0
32         )"
33
34 src_configure() {
35         local mycmakeargs=(
36                 -DBUILD_TESTING=$(usex test)
37         )
38         cmake-utils_src_configure
39 }