dev-libs/gmime: ppc64 stable wrt bug #702260
[gentoo.git] / dev-libs / console_bridge / console_bridge-0.4.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 SCM=""
7 if [ "${PV#9999}" != "${PV}" ] ; then
8         SCM="git-r3"
9         EGIT_REPO_URI="https://github.com/ros/console_bridge"
10 fi
11
12 inherit ${SCM} cmake-utils multilib
13
14 if [ "${PV#9999}" != "${PV}" ] ; then
15         KEYWORDS=""
16         SRC_URI=""
17 else
18         KEYWORDS="~amd64 ~arm"
19         SRC_URI="https://github.com/ros/console_bridge/archive/${PV}.tar.gz -> ${P}.tar.gz"
20 fi
21
22 DESCRIPTION="A ROS-independent package for logging into rosconsole/rosout"
23 HOMEPAGE="http://wiki.ros.org/console_bridge"
24 LICENSE="BSD"
25 SLOT="0/4"
26 IUSE=""
27
28 RDEPEND="dev-libs/boost:=[threads]"
29 DEPEND="${RDEPEND}"