Merge remote-tracking branch 'github/pr/608'.
[gentoo.git] / dev-libs / console_bridge / console_bridge-0.3.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 SCM=""
8 if [ "${PV#9999}" != "${PV}" ] ; then
9         SCM="git-r3"
10         EGIT_REPO_URI="https://github.com/ros/console_bridge"
11 fi
12
13 inherit ${SCM} cmake-utils multilib
14
15 if [ "${PV#9999}" != "${PV}" ] ; then
16         KEYWORDS=""
17         SRC_URI=""
18 else
19         KEYWORDS="~amd64 ~arm"
20         SRC_URI="https://github.com/ros/console_bridge/archive/${PV}.tar.gz -> ${P}.tar.gz"
21 fi
22
23 DESCRIPTION="A ROS-independent package for logging into rosconsole/rosout for ROS-dependent packages."
24 HOMEPAGE="http://wiki.ros.org/console_bridge"
25 LICENSE="BSD"
26 SLOT="0"
27 IUSE=""
28
29 RDEPEND="dev-libs/boost:=[threads]"
30 DEPEND="${RDEPEND}"