dev-libs/confuse: ia64 stable wrt bug #593804
[gentoo.git] / dev-libs / confuse / confuse-3.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit eutils multilib-minimal
8
9 DESCRIPTION="a configuration file parser library"
10 HOMEPAGE="http://www.nongnu.org/confuse/"
11 SRC_URI="https://github.com/martinh/libconfuse/releases/download/v${PV}/${P}.tar.xz"
12
13 LICENSE="ISC"
14 SLOT="0/1.0.0"
15 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ~ppc ppc64 sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
16
17 IUSE="nls static-libs"
18
19 DEPEND="sys-devel/flex
20         sys-devel/libtool
21         virtual/pkgconfig
22         nls? ( sys-devel/gettext )"
23 RDEPEND="nls? ( virtual/libintl[${MULTILIB_USEDEP}] )"
24
25 DOCS=( AUTHORS )
26
27 src_prepare() {
28         eapply_user
29         multilib_copy_sources
30 }
31
32 multilib_src_configure() {
33         # examples are normally compiled but not installed. They
34         # fail during a mingw crosscompile.
35         local ECONF_SOURCE=${BUILD_DIR}
36         econf \
37                 --enable-shared \
38                 --disable-examples \
39                 $(use_enable nls) \
40                 $(use_enable static-libs static)
41 }
42
43 multilib_src_install_all() {
44         prune_libtool_files
45
46         doman doc/man/man3/*.3
47         dodoc -r doc/html
48
49         docinto examples
50         dodoc examples/*.{c,conf}
51 }