Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / dev-libs / confuse / confuse-2.7.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=3
6
7 DESCRIPTION="a configuration file parser library"
8 HOMEPAGE="http://www.nongnu.org/confuse/"
9 SRC_URI="mirror://nongnu/confuse/${P}.tar.gz"
10
11 LICENSE="ISC"
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
14 IUSE="nls static-libs"
15
16 DEPEND="sys-devel/flex
17         sys-devel/libtool
18         virtual/pkgconfig
19         nls? ( sys-devel/gettext )"
20 RDEPEND="nls? ( virtual/libintl )"
21
22 src_configure() {
23         # examples are normally compiled but not installed. They
24         # fail during a mingw crosscompile.
25         econf \
26                 --enable-shared \
27                 --disable-examples \
28                 $(use_enable nls) \
29                 $(use_enable static-libs static)
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die
34
35         doman doc/man/man3/*.3 || die
36         dodoc AUTHORS NEWS README || die
37         dohtml doc/html/* || die
38
39         docinto examples
40         dodoc examples/*.{c,conf} || die
41 }