Merge remote-tracking branch 'github/pr/674'.
[gentoo.git] / dev-libs / cloog / cloog-0.18.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit eutils multilib-minimal
8
9 DESCRIPTION="A loop generator for scanning polyhedra"
10 HOMEPAGE="http://www.bastoul.net/cloog/"
11 SRC_URI="http://www.bastoul.net/cloog/pages/download/${P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0/4"
15 KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
16 IUSE="static-libs"
17
18 RDEPEND=">=dev-libs/gmp-5.1.3-r1[${MULTILIB_USEDEP}]
19         >=dev-libs/isl-0.12.2:0/10[${MULTILIB_USEDEP}]
20         !dev-libs/cloog-ppl"
21 DEPEND="${DEPEND}
22         virtual/pkgconfig"
23
24 DOCS=( README )
25
26 src_prepare() {
27         # m4/ax_create_pkgconfig_info.m4 includes LDFLAGS
28         # sed to avoid eautoreconf
29         sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die
30 }
31
32 multilib_src_configure() {
33         ECONF_SOURCE="${S}" econf \
34                 --with-gmp=system \
35                 --with-isl=system \
36                 $(use_enable static-libs static)
37 }
38
39 multilib_src_install_all() {
40         einstalldocs
41         prune_libtool_files
42 }