dev-libs/expat: Fix compilation (bug #622274)
[gentoo.git] / dev-libs / cloog / cloog-0.18.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit eutils multilib-minimal
7
8 DESCRIPTION="A loop generator for scanning polyhedra"
9 HOMEPAGE="http://www.bastoul.net/cloog/"
10 SRC_URI="http://www.bastoul.net/cloog/pages/download/${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0/4"
14 KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
15 IUSE="static-libs"
16
17 RDEPEND=">=dev-libs/gmp-5.1.3-r1[${MULTILIB_USEDEP}]
18         >=dev-libs/isl-0.12.2:0/10[${MULTILIB_USEDEP}]
19         !dev-libs/cloog-ppl"
20 DEPEND="${DEPEND}
21         virtual/pkgconfig"
22
23 DOCS=( README )
24
25 src_prepare() {
26         # m4/ax_create_pkgconfig_info.m4 includes LDFLAGS
27         # sed to avoid eautoreconf
28         sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die
29 }
30
31 multilib_src_configure() {
32         ECONF_SOURCE="${S}" econf \
33                 --with-gmp=system \
34                 --with-isl=system \
35                 $(use_enable static-libs static)
36 }
37
38 multilib_src_install_all() {
39         einstalldocs
40         prune_libtool_files
41 }