dev-libs/cloog: drop down to ~m68k
[gentoo.git] / dev-libs / cloog / cloog-0.18.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit eutils ltprune multilib-minimal
7
8 DESCRIPTION="A loop generator for scanning polyhedra"
9 HOMEPAGE="http://www.bastoul.net/cloog/"
10 SRC_URI="http://www.bastoul.net/cloog/pages/download/${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0/4"
14 KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
15 IUSE="static-libs"
16
17 RDEPEND=">=dev-libs/gmp-5.1.3-r1[${MULTILIB_USEDEP}]
18         >=dev-libs/isl-0.12.2:0/10[${MULTILIB_USEDEP}]"
19 DEPEND="${DEPEND}
20         virtual/pkgconfig"
21
22 DOCS=( README )
23
24 src_prepare() {
25         # m4/ax_create_pkgconfig_info.m4 includes LDFLAGS
26         # sed to avoid eautoreconf
27         sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die
28 }
29
30 multilib_src_configure() {
31         ECONF_SOURCE="${S}" econf \
32                 --with-gmp=system \
33                 --with-isl=system \
34                 $(use_enable static-libs static)
35 }
36
37 multilib_src_install_all() {
38         einstalldocs
39         prune_libtool_files
40 }