Drop $Header$ per council decision in bug #611234.
[gentoo.git] / dev-libs / cl / cl-1.2.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils multilib
6
7 DESCRIPTION="OpenCL bindings for Erlang"
8 HOMEPAGE="https://github.com/tonyrog/cl"
9 SRC_URI="${HOMEPAGE}/archive/${P}.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14
15 RDEPEND="
16         >=dev-lang/erlang-16
17         virtual/opencl
18         dev-util/rebar
19 "
20 DEPEND="${RDEPEND}"
21
22 S=${WORKDIR}/${PN}-${P}
23
24 src_compile() {
25         rebar compile || die
26 }
27
28 src_install() {
29         ERLANG_DIR="/usr/$(get_libdir)/erlang/lib"
30         CL_DIR="${ERLANG_DIR}/${P}"
31         insinto "${CL_DIR}"
32         doins -r ebin src include c_src examples
33 }