dev-python/csv23: arm64 keyworded (bug #719700)
[gentoo.git] / dev-libs / chmlib / chmlib-0.40-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit out-of-source
7
8 DESCRIPTION="Library for MS CHM (compressed html) file format"
9 HOMEPAGE="http://www.jedrea.com/chmlib/"
10 SRC_URI="http://www.jedrea.com/${PN}/${P}.tar.bz2"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ia64 ppc ppc64 x86"
15 IUSE="+examples static-libs"
16
17 PATCHES=(
18         "${FILESDIR}"/${PN}-0.39-stdtypes.patch
19         "${FILESDIR}"/${P}-headers.patch
20 )
21
22 my_src_configure() {
23         econf \
24                 $(use_enable examples) \
25                 $(use_enable static-libs static)
26 }
27
28 my_src_install_all() {
29         einstalldocs
30         find "${D}" -name '*.la' -delete || die
31 }