dev-libs/libgcrypt: arm stable, bug #623006
[gentoo.git] / dev-libs / cereal / cereal-1.2.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-utils
7
8 DESCRIPTION="header-only C++11 serialization library"
9 HOMEPAGE="http://uscilab.github.io/cereal/"
10 SRC_URI="https://github.com/USCiLab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="test"
16
17 DEPEND="test? ( dev-libs/boost )"
18
19 src_configure() {
20         mycmakeargs=(
21                 -DJUST_INSTALL_CEREAL=$(usex !test)
22                 -DWITH_WERROR=OFF
23         )
24         cmake-utils_src_configure
25 }