dev-libs/cereal: initial commit
[gentoo.git] / dev-libs / cereal / cereal-1.2.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit cmake-utils
8
9 DESCRIPTION="header-only C++11 serialization library"
10 HOMEPAGE="http://uscilab.github.io/cereal/"
11 SRC_URI="https://github.com/USCiLab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17
18 DEPEND="test? ( dev-libs/boost )"
19
20 src_prepare() {
21         sed -i 's/-Werror//' CMakeLists.txt || die
22         default
23 }
24
25 src_configure() {
26         mycmakeargs=(
27                 -DJUST_INSTALL_CEREAL=$(usex !test)
28         )
29         cmake-utils_src_configure
30 }