dev-libs/leatherman: 1.12.0 stable amd64/x86 with cleanup
[gentoo.git] / dev-libs / boxfort / boxfort-0.0.1_pre20200110.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit meson python-any-r1
9
10 BOXFORT_COMMIT="1456d9a3a3bcb506cdcd1b5d4b852e967deb5e57"
11
12 DESCRIPTION="Convenient & cross-platform sandboxing C library"
13 HOMEPAGE="https://github.com/Snaipe/BoxFort"
14 SRC_URI="https://github.com/Snaipe/BoxFort/archive/${BOXFORT_COMMIT}.tar.gz -> boxfort-${BOXFORT_COMMIT}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE="test"
20 RESTRICT="!test? ( test )"
21
22 DEPEND="test? (
23                 $(python_gen_any_dep 'dev-util/cram[${PYTHON_USEDEP}]')
24         )"
25 BDEPEND="virtual/pkgconfig"
26
27 S="${WORKDIR}/BoxFort-${BOXFORT_COMMIT}"
28
29 python_check_deps() {
30         has_version "dev-util/cram[${PYTHON_USEDEP}]"
31 }
32
33 pkg_setup() {
34         use test && python-any-r1_pkg_setup
35 }
36
37 src_configure() {
38         local emesonargs=(
39                 -Dsamples=$(usex test true false)
40                 -Dtests=$(usex test true false)
41         )
42
43         meson_src_configure
44 }