dev-libs/libpwquality: arm64 stable (bug #702260)
[gentoo.git] / dev-libs / bemenu / bemenu-0.2.0.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake-utils
7
8 DESCRIPTION="dmenu clone for wayland"
9 HOMEPAGE="https://github.com/Cloudef/bemenu"
10 if [[ ${PV} == 9999 ]]; then
11         inherit git-r3
12         EGIT_REPO_URI="https://github.com/Cloudef/bemenu.git"
13 else
14         SRC_URI="https://github.com/Cloudef/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
15         KEYWORDS="~amd64 ~arm64 ~x86"
16 fi
17
18 LICENSE="GPL-3"
19 SLOT="0"
20 KEYWORDS=""
21 IUSE="doc ncurses wayland X"
22
23 # Require at least one backend be built
24 REQUIRED_USE="|| ( ncurses wayland X )"
25
26 DEPEND="
27         ncurses? ( sys-libs/ncurses:0 )
28         wayland? (
29                 dev-libs/wayland
30                 dev-libs/wayland-protocols
31                 x11-libs/cairo
32                 x11-libs/pango
33         )
34         X? (
35                 x11-libs/libxcb
36                 x11-libs/libXext
37                 x11-libs/libX11
38                 x11-libs/cairo[X]
39                 x11-libs/pango[X]
40         )
41 "
42 RDEPEND="${DEPEND}"
43 BDEPEND="doc? ( app-doc/doxygen )"
44
45 src_configure() {
46         local mycmakeargs=(
47                 -DCURSES_LIBRARY=/usr/$(get_libdir)/libncursesw.so
48                 -DBEMENU_CURSES_RENDERER=$(usex ncurses ON OFF)
49                 -DBEMENU_WAYLAND_RENDERER=$(usex wayland ON OFF)
50                 -DBEMENU_X11_RENDERER=$(usex X ON OFF)
51         )
52         cmake-utils_src_configure
53 }
54
55 src_install() {
56         cmake-utils_src_install
57 }