dev-libs/jsoncpp: Bump subslot to 0/22
[gentoo.git] / dev-libs / bareos-fastlzlib / bareos-fastlzlib-0_pre20150524.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils
7
8 DESCRIPTION="Fork of zlib-like interface to fast block compression (LZ4 or FastLZ) libraries"
9 HOMEPAGE="https://github.com/bareos/fastlzlib"
10 SRC_URI="https://dev.gentoo.org/~mschiff/distfiles/${P}.zip"
11
12 LICENSE="BSD-1 BSD-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND=""
18 RDEPEND="${DEPEND}
19         !app-arch/lz4
20 "
21
22 S="${WORKDIR}/fastlzlib-master"
23
24 src_install() {
25         emake DESTDIR="${D}" install
26         find "${D}" -name '*.la' -delete
27         find "${D}" -type d -name libfastlz -exec rm -rf {} +
28 }