dev-libs/libax25: Drop old
[gentoo.git] / dev-libs / aws-c-event-stream / aws-c-event-stream-0.1.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake
7
8 DESCRIPTION="C99 implementation of the vnd.amazon.eventstream content-type"
9 HOMEPAGE="https://github.com/awslabs/aws-c-event-stream"
10 SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="test"
16
17 RESTRICT="!test? ( test )"
18
19 DEPEND="
20         dev-libs/aws-c-common
21         dev-libs/aws-checksums
22 "
23
24 PATCHES=(
25         "${FILESDIR}"/${PV}-add_missing_cmake_install_prefix.patch
26 )
27
28 src_configure() {
29         local mycmakeargs=(
30                 -DBUILD_TESTING=$(usex test)
31         )
32         cmake_src_configure
33 }