dev-libs/libax25: Drop old
[gentoo.git] / dev-libs / aws-c-common / aws-c-common-0.4.11.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake
7
8 DESCRIPTION="Core c99 package for AWS SDK for C"
9 HOMEPAGE="https://github.com/awslabs/aws-c-common"
10 SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="test"
16
17 RESTRICT="!test? ( test )"
18
19 src_configure() {
20         local mycmakeargs=(
21                 -DBUILD_TESTING=$(usex test)
22         )
23         cmake_src_configure
24 }