dev-lang/mozart: fix compile failures with GCC 9. Closes #722954
[gentoo.git] / dev-lang / vala / vala-0.36.20.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit gnome2
6
7 DESCRIPTION="Compiler for the GObject type system"
8 HOMEPAGE="https://wiki.gnome.org/Projects/Vala"
9
10 LICENSE="LGPL-2.1"
11 SLOT="0.36"
12 KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~x86-linux"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="
17         >=dev-libs/glib-2.32:2
18         >=dev-libs/vala-common-${PV}
19 "
20 DEPEND="${RDEPEND}
21         !${CATEGORY}/${PN}:0
22         dev-libs/libxslt
23         sys-devel/flex
24         virtual/pkgconfig
25         virtual/yacc
26         test? (
27                 dev-libs/dbus-glib
28                 >=dev-libs/glib-2.26:2
29                 dev-libs/gobject-introspection )
30 "
31
32 src_configure() {
33         # weasyprint enables generation of PDF from HTML
34         gnome2_src_configure \
35                 --disable-unversioned \
36                 VALAC=: \
37                 WEASYPRINT=:
38 }