dev-lang/vala: alpha stable wrt bug #685254
[gentoo.git] / dev-lang / vala / vala-0.36.18.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit gnome2
6
7 DESCRIPTION="Compiler for the GObject type system"
8 HOMEPAGE="https://wiki.gnome.org/Projects/Vala"
9
10 LICENSE="LGPL-2.1"
11 SLOT="0.36"
12 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
13 IUSE="test"
14
15 RDEPEND="
16         >=dev-libs/glib-2.32:2
17         >=dev-libs/vala-common-${PV}
18 "
19 DEPEND="${RDEPEND}
20         !${CATEGORY}/${PN}:0
21         dev-libs/libxslt
22         sys-devel/flex
23         virtual/pkgconfig
24         virtual/yacc
25         test? (
26                 dev-libs/dbus-glib
27                 >=dev-libs/glib-2.26:2
28                 dev-libs/gobject-introspection )
29 "
30
31 src_configure() {
32         # weasyprint enables generation of PDF from HTML
33         gnome2_src_configure \
34                 --disable-unversioned \
35                 VALAC=: \
36                 WEASYPRINT=:
37 }