dev-python/virtualenv: arm64 keyworded (bug #700918)
[gentoo.git] / dev-lang / regina-rexx / regina-rexx-3.9.1-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit autotools eutils toolchain-funcs
7
8 DESCRIPTION="Portable Rexx interpreter"
9 HOMEPAGE="https://regina-rexx.sourceforge.io/"
10 SRC_URI="mirror://sourceforge/${PN}/Regina-REXX-${PV}.tar.gz"
11
12 LICENSE="LGPL-2.1 MPL-1.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE=""
16
17 S=${WORKDIR}/Regina-REXX-${PV}
18
19 MAKEOPTS+=" -j1"
20
21 DOCS=( BUGS HACKERS.txt README.Unix README_SAFE TODO )
22
23 src_prepare() {
24         sed -e 's/CFLAGS=/UPSTREAM_CFLAGS=/' -i common/incdebug.m4 || die
25
26         eautoconf
27         tc-export CC #don't move it as tc-getCC
28 }
29
30 src_compile() {
31         emake LIBEXE="$(tc-getAR)"
32 }
33
34 src_install() {
35         default
36         newinitd "${FILESDIR}"/rxstack-r1 rxstack
37 }
38
39 pkg_postinst() {
40         elog "You may want to run"
41         elog
42         elog "\trc-update add rxstack default"
43         elog
44         elog "to enable Rexx queues (optional)."
45 }