Merge branch 'marbre-ipykernel'
[gentoo.git] / dev-lang / regina-rexx / regina-rexx-3.6-r2.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit autotools eutils toolchain-funcs
8
9 DESCRIPTION="Portable Rexx interpreter"
10 HOMEPAGE="http://regina-rexx.sourceforge.net"
11 SRC_URI="mirror://sourceforge/${PN}/Regina-REXX-${PV}.tar.gz"
12
13 LICENSE="LGPL-2.1 MPL-1.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ppc x86"
16 IUSE=""
17
18 S=${WORKDIR}/Regina-REXX-${PV}
19
20 MAKEOPTS+=" -j1"
21
22 DOCS=( BUGS HACKERS.txt README.Unix README_SAFE TODO )
23
24 src_prepare() {
25         sed -e 's/CFLAGS=/UPSTREAM_CFLAGS=/' -i common/incdebug.m4 || die
26
27         epatch "${FILESDIR}"/${PN}-3.6-gentoo.patch
28
29         eautoconf
30         tc-export CC #don't move it as tc-getCC
31 }
32
33 src_compile() {
34         emake LIBEXE="$(tc-getAR)"
35 }
36
37 src_install() {
38         default
39         newinitd "${FILESDIR}"/rxstack-r1 rxstack
40 }
41
42 pkg_postinst() {
43         elog "You may want to run"
44         elog
45         elog "\trc-update add rxstack default"
46         elog
47         elog "to enable Rexx queues (optional)."
48 }