Merge remote-tracking branch 'remotes/anomaly256/389-ds-base'
[gentoo.git] / dev-lang / rakudo / rakudo-2016.01.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 DESCRIPTION="A compiler for the Perl 6 programming language"
8 HOMEPAGE="http://rakudo.org"
9
10 if [[ ${PV} == "9999" ]]; then
11         EGIT_REPO_URI="https://github.com/rakudo/${PN}.git"
12         inherit git-r3
13 else
14         SRC_URI="${HOMEPAGE}/downloads/${PN}/${P}.tar.gz"
15 fi
16
17 LICENSE="Artistic-2"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 # TODO: add USE="javascript" once that's usable in nqp
21 IUSE="test"
22
23 RDEPEND="=dev-lang/nqp-2016.01:=[moar]"
24 DEPEND="${RDEPEND}
25         >=dev-lang/perl-5.10"
26
27 #PATCHES=(${FILESDIR}/${PV})
28
29 src_configure() {
30         perl Configure.pl --prefix=/usr --sysroot=/usr --backends=moar
31 }
32
33 src_test() {
34         export RAKUDO_PRECOMP_PREFIX=$(mktemp -d)
35         default
36 }