dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-lang / polyml / polyml-5.8.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit autotools pax-utils
7
8 DESCRIPTION="Poly/ML is a full implementation of Standard ML"
9 HOMEPAGE="https://www.polyml.org"
10 SRC_URI="https://codeload.github.com/polyml/polyml/tar.gz/v${PV} -> ${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="X elibc_glibc +gmp portable test +threads"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="X? ( x11-libs/motif:0 )
19                 gmp? ( >=dev-libs/gmp-5 )
20                 elibc_glibc? ( threads? ( >=sys-libs/glibc-2.13 ) )
21                 virtual/libffi"
22 DEPEND="${RDEPEND}"
23
24 PATCHES=(
25         "${FILESDIR}"/${PN}-5.6-configure.patch
26         "${FILESDIR}"/${PN}-5.6-ffi3.patch
27 )
28
29 src_prepare() {
30         default
31         eautoreconf
32 }
33
34 src_configure() {
35         econf \
36                 --enable-shared \
37                 --disable-static \
38                 --with-system-libffi \
39                 --with-pic=pic-only \
40                 $(use_with X x) \
41                 $(use_with gmp) \
42                 $(use_with portable) \
43                 $(use_with threads)
44 }
45
46 src_compile() {
47         # Bug 453146 - dev-lang/polyml-5.5.0: fails to build (pax kernel?)
48         pushd libpolyml || die "Could not cd to libpolyml"
49         emake
50         popd
51         emake polyimport
52         pax-mark m "${S}/.libs/polyimport"
53         emake
54         pax-mark m "${S}/.libs/poly"
55 }
56
57 src_test() {
58         emake tests
59 }