dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-lang / polyml / polyml-5.4.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit base autotools
7
8 MY_P=${PN}.${PV}
9
10 DESCRIPTION="Poly/ML is a full implementation of Standard ML"
11 HOMEPAGE="https://www.polyml.org"
12 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
13
14 LICENSE="LGPL-2.1"
15 SLOT="0/${PV}"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="X elibc_glibc +gmp portable test +threads"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="X? ( x11-libs/motif:0 )
21                 gmp? ( >=dev-libs/gmp-5 )
22                 elibc_glibc? ( threads? ( >=sys-libs/glibc-2.13 ) )"
23 DEPEND="${RDEPEND}"
24
25 S=${WORKDIR}/${MY_P}
26
27 PATCHES=("${FILESDIR}/${PN}-5.4.1-configure.patch"
28         "${FILESDIR}/${PN}-5.4.1-asm.patch")
29
30 src_prepare() {
31         base_src_prepare
32         eautoreconf
33 }
34
35 src_configure() {
36         econf \
37                 $(use_with X x) \
38                 $(use_with gmp) \
39                 $(use_with portable) \
40                 $(use_with threads)
41 }
42
43 src_test() {
44         emake tests
45 }