dev-lang/swi-prolog: version bump
[gentoo.git] / dev-lang / orc / orc-0.4.31.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit meson multilib-minimal
7
8 DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
9 HOMEPAGE="https://gstreamer.freedesktop.org/"
10 SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
11
12 LICENSE="BSD BSD-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 RESTRICT="!test? ( test )"
16 IUSE="gtk-doc static-libs test"
17
18 DEPEND=""
19 RDEPEND=""
20 BDEPEND="
21         gtk-doc? (
22                 dev-util/gtk-doc
23                 app-text/docbook-xml-dtd:4.1.2
24                 app-text/docbook-xml-dtd:4.3 )
25 "
26
27 multilib_src_configure() {
28         # FIXME: handle backends per arch? What about cross-compiling for the other arches?
29         local emesonargs=(
30                 -Ddefault_library=$(usex static-libs both shared)
31                 -Dorc-backend=all
32                 -Dorc-test=enabled # FIXME: always installs static library, bug 645232
33                 -Dbenchmarks=disabled
34                 -Dexamples=disabled
35                 $(meson_feature gtk-doc gtk_doc)
36                 $(meson_feature test tests)
37                 -Dtools=enabled # requires orc-test
38         )
39         meson_src_configure
40 }
41
42 multilib_src_compile() {
43         meson_src_compile
44 }
45
46 multilib_src_test() {
47         meson_src_test
48 }
49
50 multilib_src_install() {
51         meson_src_install
52 }