Merge remote-tracking branch 'github/pr/107'
[gentoo.git] / dev-lang / orc / orc-0.4.23.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit autotools-multilib flag-o-matic gnome2-utils
8
9 DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
10 HOMEPAGE="http://gstreamer.freedesktop.org/"
11 SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
12
13 LICENSE="BSD BSD-2"
14 SLOT="0"
15 KEYWORDS="amd64 arm hppa ppc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 IUSE="examples static-libs"
17
18 RDEPEND=""
19 DEPEND="${RDEPEND}
20         >=dev-util/gtk-doc-am-1.12
21 "
22
23 src_prepare() {
24         if ! use examples; then
25                 sed -e '/SUBDIRS/ s:examples::' \
26                         -i Makefile.am Makefile.in || die
27         fi
28
29         gnome2_environment_reset #556160
30 }
31
32 src_configure() {
33         # any optimisation on PPC/Darwin yields in a complaint from the assembler
34         # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
35         # the same for Intel/Darwin, although the error message there is different
36         # but along the same lines
37         [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
38         autotools-multilib_src_configure
39 }