Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / dev-lang / julia / julia-0.2.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4 EAPI=5
5
6 inherit eutils
7
8 DESCRIPTION="High-level, high-performance dynamic programming language for technical computing"
9
10 HOMEPAGE="http://julialang.org/"
11
12 # uses gfortran in some places, dependencies don't reflect that yet
13
14 # tarball remade because upstream lacks submodules, so it's not able to build
15 # soo ... they bundle a split out part of v8 that has no build system that makes sense
16 # double-conversion nailed in to make build system happy
17 # dSFMT is not meant to be packaged
18 SRC_URI="http://gentooexperimental.org/~patrick/${P}.tar.bz2
19         http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT/dSFMT-src-2.2.tar.gz -> dsfmt-2.2.tar.gz
20         https://double-conversion.googlecode.com/files/double-conversion-1.1.1.tar.gz"
21
22 LICENSE="MIT"
23 SLOT="0"
24
25 KEYWORDS="~amd64 ~x86"
26
27 IUSE=""
28
29 S="${WORKDIR}"
30
31 # Avoid fragile duplication - see compile and install phases
32 JULIAMAKEARGS="QUIET_MAKE= USE_SYSTEM_LLVM=1 USE_SYSTEM_READLINE=1 USE_SYSTEM_PCRE=1 USE_SYSTEM_LIBM=1 \
33                 USE_SYSTEM_GMP=1 USE_SYSTEM_LIBUNWIND=1 USE_SYSTEM_PATCHELF=1 USE_SYSTEM_FFTW=1 USE_SYSTEM_ZLIB=1 \
34                 USE_SYSTEM_MPFR=1 USE_SYSTEM_SUITESPARSE=1  USE_SYSTEM_ARPACK=1 USE_SYSTEM_BLAS=1 USE_SYSTEM_LAPACK=1 \
35                 LLVM_CONFIG=/usr/bin/llvm-config"
36
37 # scons is a dep of double-conversion
38 DEPEND="
39         =sys-devel/llvm-3.3*
40         dev-lang/perl
41         sys-libs/readline
42         dev-libs/libpcre
43         dev-util/scons
44         dev-libs/gmp
45         sys-libs/libunwind
46         dev-util/patchelf
47         sci-libs/fftw
48         sys-libs/zlib
49         dev-libs/mpfr
50         sci-libs/suitesparse
51         sci-libs/arpack
52         virtual/lapack
53         virtual/blas
54         "
55 RDEPEND="sys-libs/readline"
56
57 src_prepare() {
58         #uurgh, no fetching in ebuild
59         sed -i -e 's~$(JLDOWNLOAD)~/bin/true~' deps/Makefile || die "Oopsie"
60         sed -i -e 's~git submodule~/bin/true~g' deps/Makefile || die "Ooopsie"
61         # and we need to build stuff, so ... let's just copy around and pray!
62         mkdir -p deps/random
63         cp "${DISTDIR}/dsfmt-2.2.tar.gz" deps/random/
64         cp "${DISTDIR}/double-conversion-1.1.1.tar.gz" deps/
65         # Some cleanups to avoid an OpenBlas dep, and remove some useless git errors
66         sed -e "s|-lblas|$($(tc-getPKG_CONFIG) --libs blas)|" Make.inc || die
67         sed -e 's/$(shell git rev-parse --short=10 HEAD)/v0.2.0/' Make.inc || die
68 }
69
70 src_compile() {
71         emake $JULIAMAKEARGS || die
72         # makefile weirdness - avoid compile in src_install
73         emake $JULIAMAKEARGS debug || die
74 }
75
76 src_install() {
77         # config goes to /usr/etc/ - should be fixed
78         emake $JULIAMAKEARGS PREFIX="${D}/usr" install || die
79 }