dev-lang/ruby: arm64 stable (bug #688976)
[gentoo.git] / dev-lang / interprolog / interprolog-2.1.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit eutils java-pkg-2 java-ant-2 versionator
7
8 MY_PV="$(delete_all_version_separators)"
9 MY_P="${PN}${MY_PV}"
10
11 DESCRIPTION="InterProlog is a Java front-end and enhancement for Prolog"
12 HOMEPAGE="http://www.declarativa.com/interprolog/"
13 SRC_URI="http://www.declarativa.com/interprolog/interprolog212.zip"
14
15 LICENSE="LGPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc"
19
20 DEPEND=">=virtual/jdk-1.4
21         app-arch/unzip
22         dev-java/ant-core
23         =dev-java/junit-3.8*"
24
25 RDEPEND=">=virtual/jdk-1.4
26         =dev-java/junit-3.8*
27         || (
28                 dev-lang/xsb
29                 dev-lang/swi-prolog
30                 dev-lang/yap )"
31
32 S="${WORKDIR}"/${MY_P}
33
34 EANT_GENTOO_CLASSPATH="junit"
35
36 src_unpack() {
37         unpack ${A}
38         cd "${S}"
39
40         epatch "${FILESDIR}"/${P}-java1.4.patch
41
42         cp "${FILESDIR}"/build.xml "${S}"
43         mkdir "${S}"/src
44         mv "${S}"/com "${S}"/src
45         rm interprolog.jar junit.jar
46 }
47
48 src_compile() {
49         java-pkg_jar-from junit
50         eant jar $(use_doc)
51 }
52
53 src_install() {
54         java-pkg_dojar dist/${PN}.jar
55
56         if use doc ; then
57                 java-pkg_dohtml -r docs/*
58                 dohtml INSTALL.htm faq.htm prologAPI.htm
59                 dohtml -r images
60                 dodoc PaperEPIA01.doc
61         fi
62 }