dev-lang/hy: Old
[gentoo.git] / dev-lang / idb / idb-14.0.0.080.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 INTEL_DPN=parallel_studio_xe
8 INTEL_DID=3447
9 INTEL_DPV=2013_sp1
10 INTEL_SUBDIR=composerxe
11 INTEL_SINGLE_ARCH=false
12
13 inherit intel-sdp
14
15 _INTEL_PV1=14
16
17 DESCRIPTION="Intel C/C++/FORTRAN debugger"
18 HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
19
20 IUSE="eclipse"
21 KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
22
23 DEPEND=">=dev-libs/intel-common-13.1[compiler]"
24 RDEPEND="${DEPEND}
25         virtual/jre
26         eclipse? ( dev-util/eclipse-sdk )"
27
28 INTEL_BIN_RPMS="idb"
29 INTEL_DAT_RPMS="idb-common idbcdt"
30
31 CHECKREQS_DISK_BUILD=475M
32
33 pkg_setup() {
34         _INTEL_PV1=13 intel-sdp_pkg_setup
35 }
36
37 src_prepare() {
38         sed \
39                 -e "/^INSTALLDIR/s:=.*:=${INTEL_SDP_EDIR}:g" \
40                 -i ${INTEL_SDP_DIR}/bin/intel*/idb || die
41 }