media-video/ffmpeg: add alpha keyword
[gentoo.git] / dev-lang / gforth / gforth-0.7.3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit elisp-common eutils
8
9 DESCRIPTION="GNU Forth is a fast and portable implementation of the ANSI Forth language"
10 HOMEPAGE="https://www.gnu.org/software/gforth"
11 SRC_URI="mirror://gnu/gforth/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-freebsd ~x86-linux ~ppc-macos ~sparc-solaris"
16 IUSE="emacs"
17
18 DEPEND="dev-libs/ffcall
19         emacs? ( virtual/emacs )"
20 RDEPEND="${DEPEND}"
21
22 SITEFILE="50${PN}-gentoo.el"
23
24 src_prepare() {
25         epatch "${FILESDIR}/${PN}-0.7.0-make-elc.patch"
26         epatch_user
27 }
28
29 src_configure() {
30         # May want to add a USE flag for --enable-force-cdiv, if necessary
31         # At this point I do not know when that is appropriate, and I don't
32         # want to add an ebuild-specific USE flag without understanding.
33         econf \
34                 --without-check \
35                 $(use emacs || echo "--without-lispdir")
36 }
37
38 src_compile() {
39         # Parallel make breaks here
40         emake -j1 || die "emake failed"
41 }
42
43 src_install() {
44         emake DESTDIR="${D}" install
45
46         dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
47
48         if use emacs; then
49                 elisp-install ${PN} gforth.el gforth.elc
50                 elisp-site-file-install "${FILESDIR}/${SITEFILE}"
51         fi
52 }
53
54 pkg_postinst() {
55         use emacs && elisp-site-regen
56 }
57
58 pkg_postrm() {
59         use emacs && elisp-site-regen
60 }