dev-util/meson: 0.52.1 stable for all
[gentoo.git] / dev-lang / execline / execline-2.5.0.1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="a non-interactive scripting language"
7 HOMEPAGE="https://www.skarnet.org/software/execline/"
8 SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
9
10 LICENSE="ISC"
11 SLOT="0/$(ver_cut 1-2)"
12 KEYWORDS="~amd64 ~arm ~x86"
13 IUSE="static static-libs"
14
15 REQUIRED_USE="static? ( static-libs )"
16
17 DEPEND=">=dev-libs/skalibs-2.7.0.0[static-libs?]"
18 RDEPEND="!static? ( >=dev-libs/skalibs-2.7.0.0:= )"
19
20 HTML_DOCS="doc/*"
21
22 src_prepare() {
23         default
24
25         # Remove QA warning about LDFLAGS addition
26         sed -i "s/tryldflag LDFLAGS_AUTO -Wl,--hash-style=both/:/" "${S}/configure" || die
27
28         # configure overrides gentoo's -fstack-protector default
29         sed -i "/^tryflag CFLAGS -fno-stack-protector$/d" "${S}/configure" || die
30 }
31
32 src_configure() {
33         econf \
34                 --bindir=/bin \
35                 --dynlibdir=/$(get_libdir) \
36                 --libdir=/usr/$(get_libdir)/${PN} \
37                 --with-dynlib=/$(get_libdir) \
38                 --with-lib=/usr/$(get_libdir)/skalibs \
39                 --with-sysdeps=/usr/$(get_libdir)/skalibs \
40                 --enable-shared \
41                 $(use_enable static allstatic) \
42                 $(use_enable static static-libc) \
43                 $(use_enable static-libs static)
44 }