dev-ros/xacro: Bump to 1.12.0
[gentoo.git] / dev-lang / elixir / elixir-1.3.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit multilib
7
8 DESCRIPTION="Elixir programming language"
9 HOMEPAGE="http://elixir-lang.org"
10 SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0 ErlPL-1.1"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
15 IUSE=""
16
17 DEPEND=">=dev-lang/erlang-18[ssl]"
18 RDEPEND="${DEPEND}"
19
20 src_compile() {
21         emake Q=""
22 }
23
24 src_install() {
25         emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="/usr" install
26         dodoc README.md CHANGELOG.md CODE_OF_CONDUCT.md
27 }